Version 4.0 Hardware Requirements